Joel Moocarme

My feedback

  1. 1 vote
    Vote
    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      You have left! (?) (thinking…)
      2 comments  ·  CAM Bugs » Hardware  ·  Flag idea as inappropriate…  ·  Admin →

      Hi, here are the troubleshooting steps to try and get CAM to view your Kraken device please follow them and let me know if this works.

      If you are using a Kraken X31/X41/X61 and CAM is not detecting the device. You can try these troubleshooting steps
      Please go to the Devices Page and select “Detect Devices”
      Please exit out of CAM and install this Kraken driver https://www.dropbox.com/s/ktdih3rifenohk4/Kraken%20chip%20Driver.zip?dl=0 then restart your PC and see if CAM detects the Kraken
      Go into Control Panel and click on “View Devices and Printers” then remove the 690LC/Asetek Driver/Unknown USB Device and restart your PC. Then check CAM again.
      If you still see a Unknown USB Device, then it seems that the USB cable is creating a bad connection to the motherboard. This likely means the unit would have to be replaced. Please contact our support team over at https://www.nzxt.com/customer-support to look for an RMA

      Joel Moocarme commented  · 

      Thank you this method worked well. Why do we need to troubleshoot our hardware all the time, its a bit frustrating.
      Can you please just make the software open with our credentials already signed in, it silly to have two separate interfaces (sign-in & CAM) for software like this.

    Feedback and Knowledge Base