Nathan

My feedback

  1. 3 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  CAM Bugs » Desktop  ·  Flag idea as inappropriate…  ·  Admin →
    Nathan shared this idea  · 
  2. 1,535 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    53 comments  ·  CAM Bugs » Desktop  ·  Flag idea as inappropriate…  ·  Admin →

    Hi, if you have updated to 3.6.6 and are still having issues with your hardware or software, please open a new ticket and provide us with your logs so we can review what is happening.

    Please try to be as descriptive as possible concerning what you consider to be working incorrectly, by specifying what hardware you have and what it is not doing which it should be doing.

    This helps us greatly while trying to replicate the errors to verify why they are happening.

    Thank you.

    Nathan commented  · 

    Definitely not buying NZXT again, this software is a colossal pos, brand new issue. It won't save my settings, It asks every time to agree to blah blah and then I have to go turn off the HDD notification again. This should not be happening, it wasn't an issue in the current version I have, then all of a sudden it is. Also the program takes for effing ever to load, it should be instant.

    As of writing this I have updated it to try and resolve the problems... and now I have more... I have no fan control tab so I can't change it between silent and performance additionally it won't detect my devices.

    Seriously, replace your whole development team, this product is dogs balls and infuriating.

    !@#$%

    Not buying NZXT products that require your software again.

    Nathan supported this idea  · 
  3. 135 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    39 comments  ·  CAM Bugs » Crashing  ·  Flag idea as inappropriate…  ·  Admin →

    Hello, please try the latest update, version 3.6.6.

    Please uninstall the previous version and do a fresh install of 3.6.6.

    We have made many improvements with that version and it is working more smoothly. Let us know if this issue is still happening to you after updating. Sorry for the previous inconveniences, and thank you for your help.

    Nathan supported this idea  · 
  4. 3 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  CAM Ideas  ·  Flag idea as inappropriate…  ·  Admin →
    Nathan shared this idea  · 

Feedback and Knowledge Base