Have an idea you would like to see implemented? Post it here!

Lighting for NZXT Kraken X62 lighting doesn't change

I am having problems with my Cam software. When I try to change my lighting in my Kraken x62, the color just stays on blue (Standard Color). I think that the old Cam version was much better before. Please, please, please fix this in the next update! Spent more money on x62 because of the lights, and its very anoying that it doesn't work.

13 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    5 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Anthony commented  ·   ·  Flag as inappropriate

        My x62 isn't even detected by CAM, or windows for that matter, there is a an unknown usb device... It IS keeping my CPU at a good temperature at least, it'a just disheartening..

        Seeing the demo video showing off the new Krakken line, was all it took, better performance AND all that RGB awesomeness, I went right to the nzxt website and bought one, preorder on the spot.It sat on a shelf, in my office, still sealed in the box for about a year before I came across enough "must have" hardware/accessories to build my dream workstation.

        Then finally after spending a small fortune buying all the latest greatest hardware, and enough bling, bling to make Liberace jealous, a solid weekend of building, working into the morning trying to get the cable management perfect, then it's time... plug it into the wall, hit the power and BAM! rainbows shooting out of every opening, sparkling rays of cartoon colors everywhere, it's a glorious victory, full of pride I look into the case... and there, surrounded by pulsing,spinning psychedelia, is my x62, the logo, all white and static, staring back at me, standing out like a cop at a rave.. it's a buzzkill.

        On a serious note, I don't want to return it, I don't want a refund, I just want it to work, I want the x62 that I was promised, and paid for.

        I am gonna take a couple days and see if I can find some sort of resolution, but there are literally hundreds upon hundreds of similar complaints, and this problem with the software not detecting the hardware, at all, is pretty serious issue that apparently goes back more then 6 months, and has been getting worse instead of better...

      Feedback and Knowledge Base