Encountered an issue with CAM? Post it here!

When I exit CAM 3.5.80, an error pop up appears - Problem Event Name - CLR20r3

The software works fine in auto start-up and all, the only time I will ever encounter this issue is when I decide to exit or quit the program.

3 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Mark Sanchez shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    under review  ·  Eric Lam responded  · 

    Hi there, please perform a clean install of CAM
    Uninstall CAM completely from your PC and restart when prompted.
    Then perform a clean boot.
    To perform a clean boot, type “msconfig” in the start search and hit enter. Then select the “Services” tab and check “Hide all Microsoft Services”. Then click on “Disable all”. After, click “Apply/OK” and restart your PC.
    Then reinstall CAM from https://camwebapp.com/
    Restart when prompted
    Let me know if this helps. Thanks!
    If not please send us your error logs C:\Program Files (x86)\NZXT\CAM\Logs
    And a list of your PC specs

    14 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • AdminMax Nzxt (Admin, CAM ) commented  ·   ·  Flag as inappropriate

        Good morning Mark, we have been unable to reproduce your error on our side, please update to 3.5.9 and let us know if it continues happening.

        Thanks, and sorry for the inconvenience this is causing you.

      • Mark Sanchez commented  ·   ·  Flag as inappropriate

        I just wanted to clarify that this error happen when you right click on cam (on the task bar when it's running) and a pop up window comes up and you choose "EXIT". Once you choose "EXIT", the app closes and the error window appears with - "CAM has stopped Working". When you then choose - View problem details, you'll always see the problem event CLR20r3.

      • Mark Sanchez commented  ·   ·  Flag as inappropriate

        I also wanted to confirm that yes I have the "LIGHTING:SMART DEVICE" toggled since I use this for my H400i. It works without issues.

      • Mark Sanchez commented  ·   ·  Flag as inappropriate

        Log part 3 of 3:

        2018-05-17 06:54:23:------23.Initialize internal web server for mobile
        2018-05-17 06:54:23:going to start login
        2018-05-17 06:54:23:onto login notification changes
        2018-05-17 06:54:23:------8.Check online process
        2018-05-17 06:54:25:CAMV2.Settings.DrivesPage/UpdateUI:C:\Windows\System32\drivers\SiLib.sys- at System.Diagnostics.FileVersionInfo.GetVersionInfo(String fileName)
        at CAMV2.Settings.DrivesPage.UpdateUI(MyComputer data)
        2018-05-17 06:54:25:CAMV2.Settings.DrivesPage/UpdateUI:The method or operation is not implemented.- at CAMV2.Settings.DrivesPage.Wow64RevertWow64FsRedirection(IntPtr& oldValue)
        at CAMV2.Settings.DrivesPage.FileExists(String path)
        at CAMV2.Settings.DrivesPage.UpdateUI(MyComputer data)
        2018-05-17 06:54:25:SmartDevice 1 had been detected...
        2018-05-17 06:54:26:Send SmartDevice 1 settings to device
        2018-05-17 06:54:26:detecting NZXT Compnents
        2018-05-17 06:54:26:going to start login
        2018-05-17 06:54:26:onto login notification changes
        2018-05-17 06:54:26:------12.Hardware monitor loop update prepare.
        2018-05-17 06:54:26:going to start login
        2018-05-17 06:54:26:onto login notification changes
        2018-05-17 06:54:26:------13.Starting loopupdate
        2018-05-17 06:54:26:going to start login
        2018-05-17 06:54:26:onto login notification changes
        2018-05-17 06:54:26:------15.Start updating data
        2018-05-17 06:54:26:initialize sync cloud settings process
        2018-05-17 06:54:28:CAMV2.Hardware.GpuDBHelper`2/UpdateOrLoadCache Cloud Response: :The operation has timed out- at System.Net.HttpWebRequest.GetResponse()
        at CAMV2.Hardware.ConnectionHitTest.HitTest()
        at CAMV2.Hardware.GpuDBHelper`2.UpdateOrLoadCache()
        2018-05-17 06:54:31:CPUIDSDK/UpdateSensorTemperature:An item with the same key has already been added.- at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
        at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
        at System.Collections.Generic.Dictionary`2.Add(TKey key, TValue value)
        at CPUIDSDK.UpdateSensorTemperature()
        2018-05-17 06:54:34:start- login
        2018-05-17 06:54:34:finish- login
        2018-05-17 06:54:34:start- login
        2018-05-17 06:54:34:finish- login
        2018-05-17 06:54:34:start- login
        2018-05-17 06:54:34:finish- login
        2018-05-17 06:54:34:start- login
        2018-05-17 06:54:34:finish- login
        2018-05-17 06:54:34:start- login
        2018-05-17 06:54:34:finish- login
        2018-05-17 06:54:34:start- login
        2018-05-17 06:54:34:finish- login
        2018-05-17 06:54:34:finish- login
        2018-05-17 06:54:41:initialize cloud upload process

      • Mark Sanchez commented  ·   ·  Flag as inappropriate

        Log part 2 of 3:

        2018-05-17 05:17:03:onto login notification changes
        2018-05-17 05:17:03:------23.Initialize internal web server for mobile
        2018-05-17 05:17:04:CAMV2.Settings.DrivesPage/UpdateUI:C:\Windows\System32\drivers\SiLib.sys- at System.Diagnostics.FileVersionInfo.GetVersionInfo(String fileName)
        at CAMV2.Settings.DrivesPage.UpdateUI(MyComputer data)
        2018-05-17 05:17:04:going to start login
        2018-05-17 05:17:04:onto login notification changes
        2018-05-17 05:17:04:------8.Check online process
        2018-05-17 05:17:04:SmartDevice 1 had been detected...
        2018-05-17 05:17:05:CAMV2.Settings.DrivesPage/UpdateUI:The method or operation is not implemented.- at CAMV2.Settings.DrivesPage.Wow64RevertWow64FsRedirection(IntPtr& oldValue)
        at CAMV2.Settings.DrivesPage.FileExists(String path)
        at CAMV2.Settings.DrivesPage.UpdateUI(MyComputer data)
        2018-05-17 05:17:07:Send SmartDevice 1 settings to device
        2018-05-17 05:17:07:detecting NZXT Compnents
        2018-05-17 05:17:07:going to start login
        2018-05-17 05:17:07:onto login notification changes
        2018-05-17 05:17:07:------12.Hardware monitor loop update prepare.
        2018-05-17 05:17:07:going to start login
        2018-05-17 05:17:07:onto login notification changes
        2018-05-17 05:17:07:------13.Starting loopupdate
        2018-05-17 05:17:07:going to start login
        2018-05-17 05:17:07:onto login notification changes
        2018-05-17 05:17:07:------15.Start updating data
        2018-05-17 05:17:10:initialize sync cloud settings process
        2018-05-17 05:17:13:start- login
        2018-05-17 05:17:13:finish- login
        2018-05-17 05:17:14:start- login
        2018-05-17 05:17:14:finish- login
        2018-05-17 05:17:14:start- login
        2018-05-17 05:17:14:finish- login
        2018-05-17 05:17:14:start- login
        2018-05-17 05:17:14:finish- login
        2018-05-17 05:17:14:start- login
        2018-05-17 05:17:14:finish- login
        2018-05-17 05:17:14:start- login
        2018-05-17 05:17:14:finish- login
        2018-05-17 05:17:14:finish- login
        2018-05-17 05:17:25:initialize cloud upload process
        2018-05-17 06:00:55:CAMV2.Hardware.AzureCloud/DownLoadTuningSettings Cloud Response: :The remote server returned an error: (504) Gateway Timeout.- at System.Net.HttpWebRequest.GetResponse()
        at CAM.Utility.Helper.AzureHelper.AzureStorage_API(Dictionary`2 dicParams, String strURL, String strToken)
        at CAMV2.Hardware.AzureCloud.DownLoadTuningSettings(TuningSettingStructure& settingsData, String connectedHostName, String componentType, String time)
        2018-05-17 06:54:20:create shortcut
        2018-05-17 06:54:20:get monitor dpi
        2018-05-17 06:54:20:------1.Startup running : CAM 3.0580
        2018-05-17 06:54:20:------3.Check update3.5.80
        2018-05-17 06:54:20:------2.Initialize core process3.5.80
        2018-05-17 06:54:20:------10.Initialize object
        2018-05-17 06:54:20:core starting.
        2018-05-17 06:54:20:create task to avoid UAC
        2018-05-17 06:54:20:------4.Checked version
        2018-05-17 06:54:20:------5.OnStartup fininshed
        2018-05-17 06:54:20:------6.Initialize dashboard UI
        2018-05-17 06:54:20:------11.Initialize object finished
        2018-05-17 06:54:20:------18.Check firewall
        2018-05-17 06:54:20:judge if Firewall is Enabled
        2018-05-17 06:54:20:firewall is enable, try disable for CAM.
        2018-05-17 06:54:20:try disable firewall for CAM
        2018-05-17 06:54:20:------19.Check firewall done
        2018-05-17 06:54:20:------20.Load local FPS data
        2018-05-17 06:54:20:initialize Load FPS Local data.
        2018-05-17 06:54:20:------21.Creating CPUID SDK
        2018-05-17 06:54:20:initialize network process
        2018-05-17 06:54:20:------16.Initialize detector core
        2018-05-17 06:54:20:initialize network monitor.
        2018-05-17 06:54:21:network monitor ready.
        2018-05-17 06:54:21:load CAM settings
        2018-05-17 06:54:21:load CAM setting fail:Object reference not set to an instance of an object.- at CAMV2.MainWindow.LoadCAMSetting()
        2018-05-17 06:54:21:initialize login window
        2018-05-17 06:54:21:initialize is it first login??True
        2018-05-17 06:54:21:initialize server
        2018-05-17 06:54:21:post initialize server
        2018-05-17 06:54:21:CAMV2.Core.ComputerDataHub/SetHDDDetectionOption:Object reference not set to an instance of an object.- at CAMV2.Core.ComputerDataHub.SetHDDDetectionOption(Boolean enable)
        2018-05-17 06:54:21:post initialize server done
        2018-05-17 06:54:23:going to start login
        2018-05-17 06:54:23:onto login notification changes
        2018-05-17 06:54:23:------17.Core ready.
        2018-05-17 06:54:23:start- login
        2018-05-17 06:54:23:going to start login
        2018-05-17 06:54:23:onto login notification changes
        2018-05-17 06:54:23:------22.Start detecting devices.
        2018-05-17 06:54:23:------14.Initialize notification settings
        2018-05-17 06:54:23:initialize notification message handler
        2018-05-17 06:54:23:initialize local settings
        2018-05-17 06:54:23:going to start login
        2018-05-17 06:54:23:onto login notification changes

      • Mark Sanchez commented  ·   ·  Flag as inappropriate

        Log Part 1 of 3:

        2018-05-17 05:16:51:create shortcut
        2018-05-17 05:16:52:get monitor dpi
        2018-05-17 05:16:53:------1.Startup running : CAM 3.0580
        2018-05-17 05:16:53:------3.Check update3.5.80
        2018-05-17 05:16:53:------2.Initialize core process3.5.80
        2018-05-17 05:16:53:------10.Initialize object
        2018-05-17 05:16:53:core starting.
        2018-05-17 05:16:56:create task to avoid UAC
        2018-05-17 05:16:56:------4.Checked version
        2018-05-17 05:16:56:------5.OnStartup fininshed
        2018-05-17 05:16:57:------6.Initialize dashboard UI
        2018-05-17 05:16:57:------11.Initialize object finished
        2018-05-17 05:16:58:------18.Check firewall
        2018-05-17 05:16:58:judge if Firewall is Enabled
        2018-05-17 05:16:58:firewall is enable, try disable for CAM.
        2018-05-17 05:16:58:try disable firewall for CAM
        2018-05-17 05:16:58:------19.Check firewall done
        2018-05-17 05:16:58:------20.Load local FPS data
        2018-05-17 05:16:58:initialize Load FPS Local data.
        2018-05-17 05:16:58:------21.Creating CPUID SDK
        2018-05-17 05:16:58:initialize network process
        2018-05-17 05:16:58:------16.Initialize detector core
        2018-05-17 05:16:58:initialize network monitor.
        2018-05-17 05:16:59:network monitor ready.
        2018-05-17 05:17:01:load CAM settings
        2018-05-17 05:17:01:load CAM setting fail:Object reference not set to an instance of an object.- at CAMV2.MainWindow.LoadCAMSetting()
        2018-05-17 05:17:01:initialize login window
        2018-05-17 05:17:01:initialize is it first login??True
        2018-05-17 05:17:01:initialize server
        2018-05-17 05:17:01:post initialize server
        2018-05-17 05:17:01:CAMV2.Core.ComputerDataHub/SetHDDDetectionOption:Object reference not set to an instance of an object.- at CAMV2.Core.ComputerDataHub.SetHDDDetectionOption(Boolean enable)
        2018-05-17 05:17:01:post initialize server done
        2018-05-17 05:17:02:going to start login
        2018-05-17 05:17:02:onto login notification changes
        2018-05-17 05:17:02:------17.Core ready.
        2018-05-17 05:17:02:start- login
        2018-05-17 05:17:02:going to start login
        2018-05-17 05:17:02:onto login notification changes
        2018-05-17 05:17:02:------22.Start detecting devices.
        2018-05-17 05:17:02:------14.Initialize notification settings
        2018-05-17 05:17:03:initialize notification message handler
        2018-05-17 05:17:03:initialize local settings
        2018-05-17 05:17:03:going to start login

      • Mark Sanchez commented  ·   ·  Flag as inappropriate

        Here is the error pop up details I got when I exit the program without logging out.

        Problem signature:
        Problem Event Name: CLR20r3
        Problem Signature 01: CAM_V3.exe
        Problem Signature 02: 0.3.0.0
        Problem Signature 03: 5a98b353
        Problem Signature 04: mscorlib
        Problem Signature 05: 4.6.1076.0
        Problem Signature 06: 56d79fa2
        Problem Signature 07: 5b44
        Problem Signature 08: 26
        Problem Signature 09: FOPL4MYEJCHQ4QUDLY5M1JG1EE1KJYWU
        OS Version: 6.1.7601.2.1.0.256.48
        Locale ID: 1033
        Additional Information 1: 0a9e
        Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
        Additional Information 3: 0a9e
        Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

      • Mark Sanchez commented  ·   ·  Flag as inappropriate

        I have done a clean install of the CAM software 3 times and I can repeat the error without fail. I have tested my PC and it passes all stability tests (CPU, Memory and GPU) I've thrown at it. I just did this before going to work today and I can send you the error logs later when I get home.

        PC specs:
        4790k
        EVGA 1080ti FTW3
        Seasonic P660 80+ Titanium
        16 GB HyperX Fury Ram 2133 Mhz
        Asus Z97I-Plus
        512 GB Crucial MX100

      • Dinos commented  ·   ·  Flag as inappropriate

        It does that also for me, repeatable in every exit of the program!

        Problem signature:
        Problem Event Name: CLR20r3
        Problem Signature 01: CAM_V3.exe
        Problem Signature 02: 0.3.0.0
        Problem Signature 03: 5af26cc2
        Problem Signature 04: mscorlib
        Problem Signature 05: 4.7.2650.0
        Problem Signature 06: 5ab1cc12
        Problem Signature 07: 5cc3
        Problem Signature 08: 0
        Problem Signature 09: FOPL4MYEJCHQ4QUDLY5M1JG1EE1KJYWU
        OS Version: 6.1.7601.2.1.0.256.1
        Locale ID: 1033
        Additional Information 1: 0a9e
        Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
        Additional Information 3: 0a9e
        Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

      CAM Bugs: Crashing

      Feedback and Knowledge Base