Encountered an issue with CAM? Post it here!

Kraken x61 not detected v3.5.80

my X61 was detected by cam fine when I origionally built my system in 2014 with windows 7. Upon doing the free windows 10 upgrade cam still had no issues detecteding the x61. I have however done a complete fresh reinstall of windows 10 and CAM will now not detect my x61, the device manager finds the 690LC however will not let me update/install a driver.

19 votes
Vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
Martin shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
started  ·  AdminMax Nzxt (Admin, CAM ) responded  · 

Hi, sorry for the inconveniences you are experiencing with our software.

If you are using a Kraken X31/X41/X61 and CAM is not detecting the device. You can try these troubleshooting steps
Please go to the Devices Page and select “Detect Devices”
Please exit out of CAM and install this Kraken driver https://www.dropbox.com/s/ktdih3rifenohk4/Kraken%20chip%20Driver.zip?dl=0 then restart your PC and see if CAM detects the Kraken
Go into Control Panel and click on “View Devices and Printers” then remove the 690LC/Asetek Driver/Unknown USB Device and restart your PC. Then check CAM again.
If you still see a Unknown USB Device, then it seems that the USB cable is creating a bad connection to the motherboard. This likely means the unit would have to be replaced. Please contact our support team over at https://www.nzxt.com/customer-support to look for an RMA on the unit.
If you do not see any these devices then that means that the Kraken is not making a connection to your motherboard as Windows does not detect the driver. You may want to contact Microsoft and see if they have any input as to why your USB device is not recognized in Windows.
Try shutting off your PC, then plug the USB cable to a different USB header on your motherboard.
This is to check if the USB port on the motherboard is working correctly.
Try turning off your PC and turn off your PSU for 10 seconds, then turn your PSU and PC back on and check CAM again

In the case it does not fix the problem, please send us your PC specifications, including OS, Hardware and the Logs which you can find in the following places so we can verify any logged issues:

C:\Users\Public\Documents\CAM
C:\Program Files (x86)\NZXT\CAM\Logs

Thank you for your cooperation and time.

4 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • DeNeDe commented  ·   ·  Flag as inappropriate

    This worked for me on Windows 7 and Windows 10. Installed the USB Driver from device manager directly, rebooted the pc and now CAM shows the device.

  • chris howard commented  ·   ·  Flag as inappropriate

    I am experiencing this issue as well. CAM detects that I have a Kraken device in the "find drivers" section. Device Manager shows the proper Asetek USB Device installed. If I completely uninstall the device driver and CAM, then reinstall CAM and manually hook up the device driver, then have CAM "Detect Devices" Then and only then can I control my fan. As soon as I restart my machine, I can never control my fan again unless I repeat the above steps. I've reproed this behavior twice now.

    This is unacceptable. I cannot control the speed of my main fans and the default seems to be set dangerously low and will not increase RPM unless CAM can control it (again, when CAM does decide to work I can up my RPM and get proper cooling).

    If left like this, this constitutes a non-functional product.

CAM Bugs: Hardware

Feedback and Knowledge Base