Encountered an issue with CAM? Post it here!

NZXT USB driver error

usb driver error indication is detected from the device manager and the display of pump and LED custom function disappears from CAM Please tell me the solution method!

4 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    u_meron shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    completed  ·  AdminEric Lam (Admin, CAM ) responded  · 

    If you are using a Kraken X42/X52/X62 and CAM is not detecting the device. You can try these troubleshooting steps.

    Go into Control Panel and click on “View Devices and Printers” then remove the NZXT USB Device/Unknown USB Device and restart your PC. Then check CAM again.

    If you still see a Unknown USB Device, then it seems that the USB cable is creating a bad connection to the motherboard. You can try using a different USB cable to check and see if the USB cable that came with the package is faulty. You can use a mini to regular USB cable and route it to the back of your case to test this issue. If the cable is the issue, please contact our support team over at https://www.nzxt.com/customer-support to look for a replacement USB cable.

    Try shutting off your PC, then plug the USB cable to a different USB header on your motherboard
    This is to check if the USB port on the motherboard is working correctly.

    If you have any of the following programs below, they can come into conflict with CAM :
    Precision X, Gigabyte Xtreme Gaming, RGB Fusion, Asus Aura, MSI Mystic, Afterburner, Corsair Link. We will be working in future versions to improve compatibility between the different software programs.

    Try turning off your PC and turn off your PSU for 10 seconds, then turn your PSU and PC back on and check CAM again

    Try connecting the Kraken to a different PC/Laptop and see if it is detected in CAM. You only need to connect a external mini USB cable and see if CAM detects the unit. If it is still not detected then it is a faulty unit and we can RMA it. Please contact our support team over at https://www.nzxt.com/customer-support to look for a replacement unit.

    3 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Chris commented  ·   ·  Flag as inappropriate

        If I am running ASUS AURA will that be the reason it is showing up as unknown? Also will this affect the monitoring? The software looks to be working?

      • Nokrahs commented  ·   ·  Flag as inappropriate

        same issue here. happens randomly after reboots.
        it's always device #9 (USB device) and it's the Kraken.

      Feedback and Knowledge Base