Encountered an issue with CAM? Post it here!

Your software never works

I WILL NEVER BUY ANOTHER NZXT PRODUCT AGAIN..... YOUR SOFTWARE IS TRASH AND NEVER WORKS. The issue that says has been fixed decided to show up again and now i have to restart the software everytime i start my computer cause guess what????? IT GETS STUCK AT 0%

526 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Samuel Grooms shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    completed  ·  AdminEric Lam (Admin, CAM ) responded  · 

    Hi there, sorry for the inconvenience. The issue with the loading being stuck at 0% should be resolved now. Please update to our newest version 3.5.8 (www.camwebapp.com) and see if you still exhibit the same behavior.

    22 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  ·   ·  Flag as inappropriate

        Just to basically add what other people have said: I will never buy another NZXT product again, I'm sick and tired of the CAM software and its issues that have persisted for the past year. I'm done!

      • Danie Brink commented  ·   ·  Flag as inappropriate

        Hands down the worst piece of software I've installed in the last 35 years! Can't read CPU temperatures on a Ryzen 2600 (ALL other software reads it correctly) and causes random reboots and complete deadlocks all the time. Absolute rubbish!

      • Tyson commented  ·   ·  Flag as inappropriate

        Hi all, similar experience here. Over the past year, I have spend over $400 on NZXT components (My mistake, I know...) At first it was just a Kraken (x42), where I didn't change settings often. Then I bought a Hue+ and 2 Aer RGB fans. Words haven't even been invented yet to describe how dissatisfied I am. Over the past year, I have updated, uninstalled, wiped from my registry, run my pc in safe mode, rolled back my version and edited CAM's files, all in a hopeless bid to get it working. I honestly have never had a worse experience with software. To make matters worse, I submitted a support request, politely, though a little critical, if I'm honest, OVER A MONTH AGO AND ALL I HAVE IN RESPONSE IS THE AUTOMATED RESPONSE. I don't know if NZXT's customer service software is as terrible as CAM, which refuses to even launch (on boot, or manually), or whether they just don't care. That's not the only issue I've had, I've also been forced to log in every time, had my settings reset every launch, and a whole host of other issues - none of which I am experiencing now, which is a plus - but that's only because CAM won't even launch - which is, pretty clearly, a massive issue. Whatever the case may be, I know a lot of people in the PC building/maintenance/servicing industry, work at a computer shop, and offer advice to any who ask. Every single one of them knows about my experience so far, and now you do too. None of them will ever buy an NZXT product, and I will never buy another one. This is a complete and utter disgrace, and I'm honestly disgusted that a company can treat its customers with such carelessness. Get your s**t together NZXT. I hope I can at least get some response here from NZXT, because I'm all out of options. Next step will be spreading my story wherever I can, in order to inform people about these scam artists.

      • BOGA IT Consultants commented  ·   ·  Flag as inappropriate

        I can easily sympathise with many of the comments below and it is because of my experience with CAM software that I generally do not look for integrated solutions in my current AIO purchases. Once the novelty of the gimicky lights wears off it is just a bunch of fans and a pump. I think people need to distinguish their gripes here - CAM is just a monitoring tool, you shouldn't natively rely on this for anything nor should you trust it (someone said it report 400+ degrees F lol!). While it's cooling profiles are nice to have, typically, this can be set in any number of motherboard own tools (as I've recently discovered in my MSi motherboard BIOS)

        I do believe, however, NZXT should issue USB drivers for Asetek (the pump/lights interface hardware for windows) !SEPARATELY! because then we can deal with the lights and pump first...then make our minds up about how to use CAM...if at all.

        I installed the latest version after a recent rebuild on Windows 10 and was decidedly miffed when no drivers were installed and nor did the software detect the NZXT Kracken X61 nor could I find a suitable driver online - actually I didn't know what I needed had nothing to do with NZXT or CAM so I was floundering :( sniff

        Luckily I had a version 2.15 of CAM from 2015 - I took of the current 3.15 version did a reboot and installed the old CAM software and that found the driver and installed it straightaway.

        I was then able to upgrade to 3.05 then 3.15 - I have to agree on another point someone raised - I much prefer the 2.15 interface to this 3.15.

        Anyway - not like CAM will respond to this but I hope someone will find the fix useful.

      • Tobias commented  ·   ·  Flag as inappropriate

        100% agreed, NZXT has been forever tainted in my mind by CAM. My CPU cooler asking for my email address is not cool, my lighting asking for my facebook profile is outright evil. The fact that the software just doesn't even recognise the hardware it was built for, that is just idiotic. CAM has known lighting incompatibilities with every major motherboard software, it is bloated and consumes way too many CPU cycles and its constantly phoning home even in guest mode.

        The worst bit is that NZXT has known about these issues for years now, and done nothing to resolve them. This company deserves no more money from me or anyone i know, they are on the naughty list and blacklisted. Bad show chaps.

      • Hayaschwarz ESO commented  ·   ·  Flag as inappropriate

        Now for over a year I am struggling with CAM login issue. I am using the Kraken x61 on Windows 10, and it is really annoying to be prompted to login CAM each time you Windows starts.
        Until recently I had immediately after logging in Windows to sign out (not lock windows or sleep, the proper sign out for windows user). After I signed in to windows again, CAM was up and running properly without any issues (I didn't even had to login to CAM).
        So this is here in the hope to help some people who are struggling with the loading of CAM (it worked for me, I hope it does for you even though it is not optimal). And I hope this also help the Devs maybe figure out the issue causing it so it will be fixed properly

      • sb[nl] commented  ·   ·  Flag as inappropriate

        Years ago I asked for a simple CAM light version, with only Color/Fanspeed/Pumpspeed, with profile setup and profile selection by right clicking the system icon, just like Steelseries software.
        But I got ridiculed by the developer giving me a rough testing application probably used to test the Asetek API.

        I do not need a mammoth office VIEWER like application. It doesn't even give me the proper description of my voltages (Vin 1, 2, 3 ,4 5...etc..completely useless).

        Just give us a offline CAM light version as described, without the bells and whistles. It's those bells and whistles that make it more complicated and gives the "kid" another thing to break. It won't need maintenance and it will bring down stress on your support.

        In his spare time the developer can now play with his CAM Office version and update/change and break it at will for his loyal family, fans and friends, without bothering paying NZXT customers.

      • Xyquil Schael commented  ·   ·  Flag as inappropriate

        Hi guys. If i have 8 strips altogether connected in my HUE+ 4strips on each channel, where to connect the KRAKENX52 if im buying one? and is it possible to connect 2 NZXT HUE+ in 1 computer?

      • Anonymous commented  ·   ·  Flag as inappropriate

        I've tried everything but I cant get the software to work it always crasjes when it opens I dont know what to do so right now I have 4 fans with no lights and if i wanted that i could've bought regular fans please fix your software omg

      • Nicholas commented  ·   ·  Flag as inappropriate

        So I've been trying to get them to provide me support for CAM and my Grid fan controller for months, I get notifications like this: http://prntscr.com/iyt2bq what a joke honestly! 437° Fahrenheit I'm fairly sure my computer would have been on fire by now!!!

      • Anonymous commented  ·   ·  Flag as inappropriate

        Agreed. The x52 works best once any version of CAM is uninstalled. I simply connected the fans to the mobo set to monitor CPU temp. Their speed increases properly when I use CPU-ID to bench. Those same fans (the ones that came with the x52) stay at the same speed when plugged into the x52 harness. I can only hope the pump knows when to spin faster because without CAM there's no way to control pump speed. I'd really like to connect the pump to the PUMP pinouts on the mobo. CAM is full of bugs that are never fixed. Temps and fan speeds are always wrong. CAM SOFTWARE IS INSULTING TRASH. A CLASS ACTION LAWSUIT IS IN ORDER HERE.

      • katateochi commented  ·   ·  Flag as inappropriate

        Yep once again, CAM is failing to load and then when it does it's reporting 0 as my cpu temp and a clock speed of -1MHz. It's not like this is the software for some trivial peripheral, this is the software that controls the most important temperature regulation in the system, yet it's less stable than my demented grandmother.

        Your hardware is awesome and I've been buying NZXT cases for years, but I am so vexed by your software that I'm not going to be a customer anymore. It's even more vexing that despite our continual ranting about your inexplicably shoddy software, you won't do anything about it. CAM is beyond repair in my view, throw it out and start again, and this time don't let your interns design or write the code for it.

      • Nathan commented  ·   ·  Flag as inappropriate

        Will buy their cases... not anything else. Absolute trash software with false resolutions.

      • Eugene commented  ·   ·  Flag as inappropriate

        I was happy to purchase the V2 fan controller by NZXT. Unfortunately I quickly discovered that the CAM software it comes with is a buggy mess. Instead of making it more streamlined, lighter on resources and user customizable it is becoming quite the opposite update after update. What bothers me the most is its unreliability, I prefer not use the cloud option in CAM. For this reason every time the app starts it keeps asking me to login or continue as guest. I simply do not want to see this login prompt and start app locally. Please provide us with an option to completely disable the cloud side of the app and use it locally...and yes this means absolutely no data transfers from our computers when the cloud is disabled! Due to mentioned issues the V2 fan controller is the last product I will ever buy from NZXT and I will make sure to warn other via review on Amazon from making the same mistake.

      • LouGui commented  ·   ·  Flag as inappropriate

        Le dispositif RGB est une grosse merde ! Le logiciel fonctionne jamais ! A chaque update un bug...

      • Anonymous commented  ·   ·  Flag as inappropriate

        Yes, same. I never tried anything from NZXT before but i only heard good things, i dont know if they are paying people to say good stuff about them or something... I wish someone warned me and i wouldnt have bought thier shitty AIO. I have to keep restarting my pc multiple times until the pump actually gets recognised and starts, to keep my GPU from overheating. Since i got thier kraken g12 for my gpu i just thohught it would be a good idea to get their 120mm AIO to go with it, but shit barely works 1/5 of the time. My Corsair h100i has been going forever now and i have never had a single problem with it not working. Software is also actually useful, and most of all it works properly. And I would honestly be fine with a crappy software if just the goddamned AIO worked so i didn't have to go in and monitor my GPU temps every time i start my pc to see if the pump is actually pumping or not.

      ← Previous 1

      Feedback and Knowledge Base