Encountered an issue with CAM? Post it here!

CAM 3.3.5 Overlay not working for most games!

The overlay isn't working with most of my games which is odd because it was working just fine about 2 weeks ago. I think it might have been an update that caused it to stop working but the only game it works on at thew moment is Overwatch.

459 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    David Caldwell shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    under review  ·  AdminEric Lam (Admin, CAM ) responded  · 

    Hi there, please be sure you are on the latest version of CAM from camwebapp.com. The most current version is 3.5.3

    The overlay requires DirectX Runtime to be installed.
    Please install DX Runtime and then restart your PC and see if the overlay works. The link below will take you to the download site for the installer.
    https://www.microsoft.com/en-us/download/details.aspx?id=35

    Also make sure that you have tried manually enabling the overlay with the short keys (Shift + O). These shortcut keys can be changed from settings in CAM as well.

    If the instructions above does not work please let us know which games the overlay is not working on.

    151 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Snake commented  ·   ·  Flag as inappropriate

        Updating it won't help, DirectX Runtime is installed... it works for me with only one game Mount and Blade Warband of the 104 games I tried it on.... I'm very sorry to say that at this moment i'm not building anymore pc for people with NZXT hardware because of CAM... I love the idea, the product is terrible.

      • Alan commented  ·   ·  Flag as inappropriate

        Overlay doesn't work here either. This CAM software is the worst I've ever seen. It was always buggy, they can't seem to get it right. Sorry to say, but this might be my last NZXT product ever.

      • Dave commented  ·   ·  Flag as inappropriate

        I found recently that CAM doesn't play well with the Corsair Utility Engine (Corsair CUE) 3.1.131

        This may be isolated but might be worth a shot to some to try rebooting with CUE disabled and see if CAM behaves.

      • DKsDEVIL commented  ·   ·  Flag as inappropriate

        pleas fix the new version, the OSD ust dont work.
        i downgraded to 3.171 and i work fine

      • David commented  ·   ·  Flag as inappropriate

        It also does not work in world of Warcraft 7.3.5. I have done all steps to fix this with no luck

      • Anonymous commented  ·   ·  Flag as inappropriate

        Hi I have the same problem, It does not work in PUBG, ARK survival evolved, Rust and some more, any solution?

      • Anonymous commented  ·   ·  Flag as inappropriate

        HEY NZXT - WOULD YOU LOOK AT ALL THESE FUCKING COMMENTS. EVERYONE HERE SPENT $100+ ON YOUR "PREMIUM" PRODUCT. The hardware works. Good job. I love it. They love it. Everyone loves it. BUT PART OF WHAT MAKES YOUR PRODUCT COOL IS THE SOFTWARE. IF YOU DON'T GIVE YOUR CUSTOMERS THE WHOLE PACKAGE, THEY BEGIN TO THINK YOU'RE EITHER INCOMPETENT OR A BUNCH OF ASSHOLES. Either way, both are bad for business. Please. PLEASE. Get. this. fucking. fixed. Or I swear to fucking Jesus's holy dick that your business won't be around for 5 more years. Good luck.

      • javier.ruiz.alcaraz commented  ·   ·  Flag as inappropriate

        I uninstalled afterburner thinking that CAM should be the solution, but overlay don't runs in a lot of my games like PUBG. (Afterburner yes) I think I will have to reinstall it again...

      • Setau commented  ·   ·  Flag as inappropriate

        Not working with forza horizon3 and watch dogs2. Works fine in witcher3, rise of tomb raider and other "actual" games.
        Really great software however, thx devs for not make us pay for it.

      • J commented  ·   ·  Flag as inappropriate

        Having the same problem, the only game this works in is battlefield 1 that I have.
        Games it does not work in that I have tried, even if I manually enable the overlay.
        I have up to date windows and DirectX runtime.

        ABZU, Playerunknowns Battlegrounds
        Project Cars 2
        Rise of the tomb Raider

      • Peter B commented  ·   ·  Flag as inappropriate

        How is this company still in business? All i see on the internet is complains that dont get resolved, but have closed threads to hide the issues. This company is a scam and i will never buy or recommend anything from them again

      ← Previous 1 3 4 5 6 7 8

      CAM Bugs: Desktop

      Feedback and Knowledge Base