Encountered an issue with CAM? Post it here!

CAM displaying wrong CPU temp

Just got CAM installed with a Kraken X61 but the software is showing a different CPU temperature than what is shown on the motherboard and in Open Hardware Monitor. I had the Corsair H100i before this and the Corsair Link software let me link the fan speed with whatever sensor I wanted. Why would the CAM software be showing a different temp than the CPU is actually producing? Maybe make an option to choose which sensor to use for CPU monitoring??

11 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Jordan shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    26 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  ·   ·  Flag as inappropriate

        Just finished installing Nzxt M22. It seems Tomshardware best pick will disappoint me. Notification say exceeding 80 to 82 while AMD Overdrive say 36.9 to 37.5

      • Anonymous commented  ·   ·  Flag as inappropriate

        Also had crazy readings at 8k+ C. The computer would melt, the table would melt and then I would melt. When I check it under heavy loads it spikes around 80, but the notifications are fucked.

      • [Deleted User] commented  ·   ·  Flag as inappropriate

        was doing a stresstest on mine, it was at 80-83 C but i kept on getting notifications saying it had gone past 8386 C....

      • Anonymous commented  ·   ·  Flag as inappropriate

        Also 2700, cam application shows temps in excess of 80°C then HWinfo64, HWMonitor, and BIOS show 30-40°C. This is severely screwing with my fan curve...worked fine alongside my FX 8350 though.

      • Edward Allen commented  ·   ·  Flag as inappropriate

        Me too. Ryzen 2700X on an MSI x420 Gaming M7 AC. The temperature is incorrect, but in the MSI software and in hwinfo it is correct. Frustrating because i really wanted the color to match the temperature and not just be dark scary red.

      • Preben Trustrup commented  ·   ·  Flag as inappropriate

        Have the same problem with my new ROG STRIX X470 F Gameing MB. found out that if i roll back to the 0225 bios driver i do get the right temp readings. freaked me out for a while.

      • Ty Rymer commented  ·   ·  Flag as inappropriate

        it seems to take the Fahrenheit temperature and use it as Celsius. I have the same problem. Cam shows me a temperature of max 90°C and min 79°C which doesn't make sense after having tried to replace my Kraken x62 with the included stock cooler and the temperatures still being in the same range at idle. whilst if I convert the temperatures to °C from °F I get about 26°C to 32°C which makes a lot more sense. (i replaced the cooler thinking the pump was broken btw... but it turned out not to be the case)

      • Jim Fairman commented  ·   ·  Flag as inappropriate

        Same here with Ryzen 2700X on ASUS ROG STRIX x470-F motherboard. CPU being reported as 100C in CAM, but only 40C in AIsuite.

      • Will commented  ·   ·  Flag as inappropriate

        Same problem. Ryzen 2700x. Asus Hero VII mobo. CAM is reporting it more than 60 degrees higher than the BIOs / RyzenMaster

      • Danie Brink commented  ·   ·  Flag as inappropriate

        Same Problem (Ryzen 5 2600) CPU temperature is always displaying 40C above the true temperature reported in both the BIOS & RyzenMaster (Current real temperature = 35C, CAM reporting = 75C)

      • Chevy commented  ·   ·  Flag as inappropriate

        CAM is showing wrong temperatures, I was going crazy at first it was saying over 100C but in the bios is showing 34C-44C Idle, and in MSI Command Center it Shows same as in BIOS, CAM software is showing obscene temps

      • Bill commented  ·   ·  Flag as inappropriate

        At idle I get warnings such as your CPU temp has exceeded 160.62C degrees. Prolonged use at this temperature may shorten your CPU's lifespan. Neither CAM nor HWMonitor shows in the HIGH/CURRENT/LOW temp readings of anywhere approaching that. I'm using an AMD-9590 chipset.

      • Anonymous commented  ·   ·  Flag as inappropriate

        The temps on CAM are incorrect. Using CAM CPU i9 7900Xtemps where around 75C where using HWMonitor and RealTemp there were at 93C! I like this software but had to uninstall it as it was useless with incorrect temps

      • Anonymous commented  ·   ·  Flag as inappropriate

        CPU Temperature shown in the DirectX Overlay and the temperature shown in CAM are totally different.

        The CPU temp shown in CAM Applications agrees with Open Hardware Monitor. But the temperature shown in CAM Overlay is totally different to CAM Application, roughly double.

      • Troy commented  ·   ·  Flag as inappropriate

        Just got CAM installed and was shocked with the TEMP of my CPU. It averages from 68C to 82C after just turning it on. I installed AMD Overdrive and checked the Thermal Margin. It only shows as 41C to 45C. This is the latest version. How can this be fixed? I wanted to post a screen shot but it does not a allow me to.

      ← Previous 1

      CAM Bugs

      Feedback and Knowledge Base